import re
regex = re.compile(r"(狐狸)", flags=re.MULTILINE)
test_str = ("Sample text for testing:\n"
"跑叫碰\n"
"What Does the Fox Say? 12 狐狸怎叫 34\n"
"What Does the shiba inu say? 柴犬怎叫\n"
"怎麼叫起來像柴犬\n"
"怎麼叫起來像狐狸\n"
"狐獴(學名:Suricata suricatta)是细尾獴属的唯一物種,屬食肉目獴科,居住在南非、納米比亞及安哥拉西南部的喀拉哈里沙漠。\n"
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
"0123456789 +-.,!@#$%^&*();\\\\/|<>\\\"\\'\n"
"12345 -98.7 3.141 .6180 9,000 +42\n"
"555.123.4567 +1-(800)-555-2468\n"
"foo@demo.net bar.ba@test.co.uk\n"
"www.demo.com http://foo.co.uk/\n"
"http://regexr.com/foo.html?q=bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")