using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^UTC[+-]\d{2}[:]\d{2}$";
string input = @"UTC+02:00";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}