$re = '/^UTC[+-]\d{2}[:]\d{2}$/';
$str = 'UTC+02:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);