package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^UTC[+-]\d{2}[:]\d{2}$`)
var str = `UTC+02:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}