#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.+\.\n(?:\s+.+\n?)+)"
Local $sString = "TestSuite1." & @CRLF & _
" TestCase1" & @CRLF & _
" TestCase2" & @CRLF & _
"TestSuite2." & @CRLF & _
" TestCase1" & @CRLF & _
" TestCase2" & @CRLF & _
" TestCase3" & @CRLF & _
"TestSuite3." & @CRLF & _
" TestCase1" & @CRLF & _
" TestCase2" & @CRLF & _
" TestCase3" & @CRLF & _
" TestCase4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")