$re = '/(.+\.\n(?:\s+.+\n?)+)/';
$str = 'TestSuite1.
TestCase1
TestCase2
TestSuite2.
TestCase1
TestCase2
TestCase3
TestSuite3.
TestCase1
TestCase2
TestCase3
TestCase4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);