const regex = /(.+\.\n(?:\s+.+\n?)+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+\\.\\n(?:\\s+.+\\n?)+)', 'g')
const str = `TestSuite1.
TestCase1
TestCase2
TestSuite2.
TestCase1
TestCase2
TestCase3
TestSuite3.
TestCase1
TestCase2
TestCase3
TestCase4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}