package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<xml:jus id="\d+" trek="\w+" place="downward">(*SKIP)(*F)|<xml:jus id="\d+" trek="\w+" place="[^"]+">`)
var str = `<xml:jus id="84" trek="spanned" place="downward">
<xml:jus id="84" trek="spanned" place="upward">
<xml:jus id="84" trek="spanned" place="New York">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}