// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<xml:jus id="\d+" trek="\w+" place="downward">(*SKIP)(*F)|<xml:jus id="\d+" trek="\w+" place="[^"]+">"#).unwrap();
let string = "<xml:jus id=\"84\" trek=\"spanned\" place=\"downward\">
<xml:jus id=\"84\" trek=\"spanned\" place=\"upward\">
<xml:jus id=\"84\" trek=\"spanned\" place=\"New York\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}