$re = '/ \(\?P<(\w+)> # named group (name captured as group 1): (?P<name>
( # matching pattern as group (2) in form: b(R1)a1...(R2)a2
[^)(]*+ # `b` (before) part - any not `)(` characters
(?: # non capturing group for repeated `(R)a`
\((?2)\) # `R` - reference to group 2 for possible nested braces
[^)(]*+ # \'a\' (after) part - any not `)(` characters
)* # `(R)a` repetition is optional
) # end the group 2
\) # end of the named group to match/x';
$str = '(?P<kind>(frames_cleanpass)|(disparity))/(?P<subset>\\w+)/(?P<scene_1>\\w+)/(?P<scene_2>\\w+)/(?P<side>\\w+)/(?P<scene_3>\\w+)\\.(?P<ext>(?(3)pfm|png))';
$subst = "{\1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;