using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*:.*[\\][^:\n]*):";
string input = @"sds4:kwertss\wegggds:
sds4:kwertss\wegggds
RRR:domsd\ddf:sdf:dsf:f
sds4:kwertss\wegggds:rowdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}