$re = '/(.*:.*[\\\\][^:\n]*):/';
$str = 'sds4:kwertss\\wegggds:
sds4:kwertss\\wegggds
RRR:domsd\\ddf:sdf:dsf:f
sds4:kwertss\\wegggds:rowdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);