package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*:.*[\\][^:\n]*):`)
var str = `sds4:kwertss\wegggds:
sds4:kwertss\wegggds
RRR:domsd\ddf:sdf:dsf:f
sds4:kwertss\wegggds:rowdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}