import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\{\\{mecha.*?\\}\\})(?<!\\{\\{track.*?\\}\\})(\\{\\{track)";
final String string = "{{mecha|p=Neutron Stampeder}}{{track|p=Ignited}}{{track|p=Ignited}}\n\n"
+ "{{track|p=Mizu no Akashi}}\n\n"
+ "{{track|p=Mizu no Akashi}}";
final String subst = "|tracks=$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}