re = /(?<=\{\{mecha.*?\}\})(?<!\{\{track.*?\}\})(\{\{track)/m
str = '{{mecha|p=Neutron Stampeder}}{{track|p=Ignited}}{{track|p=Ignited}}
{{track|p=Mizu no Akashi}}
{{track|p=Mizu no Akashi}}'
subst = '|tracks=$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result