import re
regex = re.compile(r"(?<=\{\{mecha.*?\}\})(?<!\{\{track.*?\}\})(\{\{track)", flags=re.MULTILINE)
test_str = ("{{mecha|p=Neutron Stampeder}}{{track|p=Ignited}}{{track|p=Ignited}}\n\n"
"{{track|p=Mizu no Akashi}}\n\n"
"{{track|p=Mizu no Akashi}}")
subst = "|tracks=$1"
result = regex.sub(subst, test_str)
if result:
print(result)