import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http:\\/\\/pre.m[1|2]?.lacaixa.es:80\\/SPD\\/docs\\/general\\/APPatencio(Lite)?_(es|ca|en|eu|gl)\\.html";
final String string = "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html\n"
+ "Amb targeta: \n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html\n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_ca.html\n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_en.html\n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_eu.html\n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_gl.html \n"
+ " \n"
+ "Sense targeta: \n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_es.html\n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_ca.html\n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_en.html\n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_eu.html\n"
+ "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_gl.html\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}