// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http:\/\/pre.m[1|2]?.lacaixa.es:80\/SPD\/docs\/general\/APPatencio(Lite)?_(es|ca|en|eu|gl)\.html").unwrap();
let string = "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html
Amb targeta:
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_ca.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_en.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_eu.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_gl.html
Sense targeta:
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_es.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_ca.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_en.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_eu.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_gl.html
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}