const regex = /^http:\/\/pre.m[1|2]?.lacaixa.es:80\/SPD\/docs\/general\/APPatencio(Lite)?_(es|ca|en|eu|gl)\.html/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http:\\\/\\\/pre.m[1|2]?.lacaixa.es:80\\\/SPD\\\/docs\\\/general\\\/APPatencio(Lite)?_(es|ca|en|eu|gl)\\.html', 'gm')
const str = `http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html
Amb targeta:
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_ca.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_en.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_eu.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_gl.html
Sense targeta:
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_es.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_ca.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_en.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_eu.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_gl.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}