#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!/)/[^/\n]*$"
Local $sString = "http://200.175.79.171:8000/;stream.nsv" & @CRLF & _
"http://162.221.185.250:9314" & @CRLF & _
"http://radio2.suaradionanet.net:8044/;stream.mp3" & @CRLF & _
"http://centova2.euroti.com.br:8443/stream" & @CRLF & _
"http://sc4.dnip.com.br:11260" & @CRLF & _
"http://c1.fabricahost.com.br:8092/stream" & @CRLF & _
"http://rvn01.estudioproarte.com.br:8444/stream" & @CRLF & _
"http://wz4.dnip.com.br/fmpontao/fmpontao.stream/playlist.m3u8" & @CRLF & _
"http://stm8.xcast.com.br:9770/" & @CRLF & _
"http://209.126.127.125:8348/live" & @CRLF & _
"http://stm7.pagehost.com.br:27292/;?1508412260756" & @CRLF & _
"http://69.162.64.252:8692/live" & @CRLF & _
"http://rvn01.painelstream.net:8638" & @CRLF & _
"http://2.stm-ip.com:8578/;stream.mp3" & @CRLF & _
"http://stm51.streamingbage.net.br:18164" & @CRLF & _
"http://audio1.cmaudioevideo.com:8346/stream" & @CRLF & _
"http://radio.radionaturezafm.com.br:9994" & @CRLF & _
"http://srv-stream.sisdera.com:8000/SOCIEDADECARNAVA" & @CRLF & _
"http://stm1.srvaudio.com.br:9422/;type=mp3" & @CRLF & _
"https://streaming.speedrs.com.br/radio/8050/jaboticaba" & @CRLF & _
"http://hts03.kshost.com.br:8014/live"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")