import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!/)/[^/\\n]*$";
final String string = "http://200.175.79.171:8000/;stream.nsv\n"
+ "http://162.221.185.250:9314\n"
+ "http://radio2.suaradionanet.net:8044/;stream.mp3\n"
+ "http://centova2.euroti.com.br:8443/stream\n"
+ "http://sc4.dnip.com.br:11260\n"
+ "http://c1.fabricahost.com.br:8092/stream\n"
+ "http://rvn01.estudioproarte.com.br:8444/stream\n"
+ "http://wz4.dnip.com.br/fmpontao/fmpontao.stream/playlist.m3u8\n"
+ "http://stm8.xcast.com.br:9770/\n"
+ "http://209.126.127.125:8348/live\n"
+ "http://stm7.pagehost.com.br:27292/;?1508412260756\n"
+ "http://69.162.64.252:8692/live\n"
+ "http://rvn01.painelstream.net:8638\n"
+ "http://2.stm-ip.com:8578/;stream.mp3\n"
+ "http://stm51.streamingbage.net.br:18164\n"
+ "http://audio1.cmaudioevideo.com:8346/stream\n"
+ "http://radio.radionaturezafm.com.br:9994\n"
+ "http://srv-stream.sisdera.com:8000/SOCIEDADECARNAVA\n"
+ "http://stm1.srvaudio.com.br:9422/;type=mp3\n"
+ "https://streaming.speedrs.com.br/radio/8050/jaboticaba\n"
+ "http://hts03.kshost.com.br:8014/live";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}