use strict;
my $str = 'http://200.175.79.171:8000/;stream.nsv
http://162.221.185.250:9314
http://radio2.suaradionanet.net:8044/;stream.mp3
http://centova2.euroti.com.br:8443/stream
http://sc4.dnip.com.br:11260
http://c1.fabricahost.com.br:8092/stream
http://rvn01.estudioproarte.com.br:8444/stream
http://wz4.dnip.com.br/fmpontao/fmpontao.stream/playlist.m3u8
http://stm8.xcast.com.br:9770/
http://209.126.127.125:8348/live
http://stm7.pagehost.com.br:27292/;?1508412260756
http://69.162.64.252:8692/live
http://rvn01.painelstream.net:8638
http://2.stm-ip.com:8578/;stream.mp3
http://stm51.streamingbage.net.br:18164
http://audio1.cmaudioevideo.com:8346/stream
http://radio.radionaturezafm.com.br:9994
http://srv-stream.sisdera.com:8000/SOCIEDADECARNAVA
http://stm1.srvaudio.com.br:9422/;type=mp3
https://streaming.speedrs.com.br/radio/8050/jaboticaba
http://hts03.kshost.com.br:8014/live';
my $regex = qr/(?<!/)/[^/\n]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}