import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{% +([a-z]+) +IF:.*? +%\\}\\r?\\n(?:^.*\\r?\\n)*?\\{% +\\1 +ENDIF +%\\}$";
final String string = "{% name IF: a EQUALS b %}\n\n"
+ "content\n\n"
+ "{% name ENDIF %}\n\n"
+ "{% Saffi IF: my { % dog } has fleas %}\n\n"
+ "content\n\n"
+ "{% Saffi ENDIF %}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}