$re = '/{% +([a-z]+) +IF:.*? +%}\r?\n(?:^.*\r?\n)*?{% +\1 +ENDIF +%}$/mi';
$str = '{% name IF: a EQUALS b %}
content
{% name ENDIF %}
{% Saffi IF: my { % dog } has fleas %}
content
{% Saffi ENDIF %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);