re = /{% +([a-z]+) +IF:.*? +%}\r?\n(?:^.*\r?\n)*?{% +\1 +ENDIF +%}$/mi
str = '{% name IF: a EQUALS b %}
content
{% name ENDIF %}
{% Saffi IF: my { % dog } has fleas %}
content
{% Saffi ENDIF %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end