package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{2}-\d{3}\b`)
var str = `Street 50, 50-123 City
23-123 or
50-530.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}