$re = '/\b\d{2}-\d{3}\b/m';
$str = 'Street 50, 50-123 City
23-123 or
50-530.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);