const regex = /\b\d{2}-\d{3}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{2}-\\d{3}\\b', 'gm')
const str = `Street 50, 50-123 City
23-123 or
50-530.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}