package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms).*?<tag>.+?content.+?<\/tag>`)
var str = `<tag>
...
</tag>
tag>
...
content
...
</tag>
<tag>
...
content
...
</tag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}