re = /.*?<tag>.+?content.+?<\/tag>/m
str = '<tag>
...
</tag>
tag>
...
content
...
</tag>
<tag>
...
content
...
</tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end