$re = '/.*?<tag>.+?content.+?<\/tag>/ms';
$str = '<tag>
...
</tag>
tag>
...
content
...
</tag>
<tag>
...
content
...
</tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);