#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]\d*|0)(?:\.\d{1,2})?$"
Local $sString = "0.01" & @CRLF & _
"1.1" & @CRLF & _
"1.02" & @CRLF & _
"120.01" & @CRLF & _
"" & @CRLF & _
"0023" & @CRLF & _
"0100" & @CRLF & _
".01" & @CRLF & _
".12" & @CRLF & _
"00.4" & @CRLF & _
"001.02" & @CRLF & _
"0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")