$re = '/^(?:[1-9]\d*|0)(?:\.\d{1,2})?$/m';
$str = '0.01
1.1
1.02
120.01
0023
0100
.01
.12
00.4
001.02
0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);