// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[1-9]\d*|0)(?:\.\d{1,2})?$").unwrap();
let string = "0.01
1.1
1.02
120.01
0023
0100
.01
.12
00.4
001.02
0000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}