import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![0.]+$)(?:[1-9]\\d*|0)(?:\\.\\d{1,2})?$";
final String string = "0.01\n"
+ "1.1\n"
+ "1.02\n"
+ "120.01\n\n"
+ "0.0\n"
+ "0.00\n"
+ "0023\n"
+ "0100\n"
+ ".01\n"
+ ".12\n"
+ "00.4\n"
+ "001.02\n"
+ "0000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}