use strict;
my $str = '0.01
1.1
1.02
120.01
0.0
0.00
0023
0100
.01
.12
00.4
001.02
0000';
my $regex = qr/^(?![0.]+$)(?:[1-9]\d*|0)(?:\.\d{1,2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}