package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\b22\b,{0,1}.*`)
var str = `29,30,31,32,33,34,35,36,192,225,228,233,239,240,144,145`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}