$re = '/.*\b22\b,{0,1}.*/m';
$str = '29,30,31,32,33,34,35,36,192,225,228,233,239,240,144,145';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);