const regex = /.*\b22\b,{0,1}.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\b22\\b,{0,1}.*', 'gm')
const str = `29,30,31,32,33,34,35,36,192,225,228,233,239,240,144,145`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}