using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[U][A]-\d{5,10}-\d{0,2}";
string input = @"UA-1545415-12";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}