$re = '/[U][A]-\d{5,10}-\d{0,2}/';
$str = 'UA-1545415-12';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);