package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[U][A]-\d{5,10}-\d{0,2}`)
var str = `UA-1545415-12`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}