#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z]+'[a-zA-Z]+?|[a-zA-Z]+"
Local $sString = "Hello my name is Cole. I can't believe this is really working" & @CRLF & _
"'Let's try this now'" & @CRLF & _
"!@#$%^&*()_+-=[]\{}|;':"`~,./<>?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")