package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]+'[a-zA-Z]+?|[a-zA-Z]+`)
var str = `Hello my name is Cole. I can't believe this is really working
'Let's try this now'
!@#$%^&*()_+-=[]\{}|;':"\`~,./<>?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}