// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-zA-Z]+'[a-zA-Z]+?|[a-zA-Z]+").unwrap();
let string = "Hello my name is Cole. I can't believe this is really working
'Let's try this now'
!@#$%^&*()_+-=[]\\{}|;':\"`~,./<>?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}