const regex = /^([1-9]{1}[0-9]{8}[VvXx])|([1-9]{1}[0-9]{11})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]{1}[0-9]{8}[VvXx])|([1-9]{1}[0-9]{11})$', 'gm')
const str = `880053611V
198800503611
978561353V
199785601355
920600073V
199206000073`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}