using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\<soafault:faultDescription\>)|(\""faultDescription\""\s+:\s+\""))(?<faultDescription>[^\""\<]+)";
string input = @"""faultDescription"" : ""Backend system error has occurred."",
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}