re = /^((\<soafault:faultDescription\>)|(\"faultDescription\"\s+:\s+\"))(?<faultDescription>[^\"\<]+)/m
str = '"faultDescription" : "Backend system error has occurred.",
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end