#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![-\.\d])(?:0{0,2}?[0-9]\.|1\d?\d?\.|2[0-5]?[0-5]?\.){3}(?:0{0,2}?[0-9]|1\d?\d?|2[0-5]?[0-5]?)(?![\.\d])"
Local $sString = "str1 = 'Hello my name is Ben and my IP address is 256.0.0.0'" & @CRLF & _
"negative number is invalid: -127.2.1.2" & @CRLF & _
"valid: 001.001.001.001" & @CRLF & _
"str2 = 'Hello my name is Folks and my IP address is 1.2.3.4.5'" & @CRLF & _
"str3 = 'Hello all, ip addresses: 111.2.3., ip:0.0.0.0, 127.2.1.2'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")