re = /(?<![-\.\d])(?:0{0,2}?[0-9]\.|1\d?\d?\.|2[0-5]?[0-5]?\.){3}(?:0{0,2}?[0-9]|1\d?\d?|2[0-5]?[0-5]?)(?![\.\d])/m
str = 'str1 = \'Hello my name is Ben and my IP address is 256.0.0.0\'
negative number is invalid: -127.2.1.2
valid: 001.001.001.001
str2 = \'Hello my name is Folks and my IP address is 1.2.3.4.5\'
str3 = \'Hello all, ip addresses: 111.2.3., ip:0.0.0.0, 127.2.1.2\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end